HDU 1016 Prime Ring Problem【第一次DFS的邂逅】

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34498    Accepted Submission(s): 15267


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

 

注意:

1:在fun函数里面的i不可以用作全局变量 因为DFS的递归(函数调用)会影响i的值 所以i只能在fun函数里面定义(PS:除非i在递归中没有数值的影响)

2:深搜的模板(自己编的)

void fun(int a)
{
    if()/*剪枝的条件*/
    {
        ;
    }
    if()/*非法情况的条件*/
    {
        ;
    }
    if()/*最深层递归的跳出条件*/
    {
        ;
    }    
        if()/*继续递归条件*/
    {
        vis[i]=false;/*深搜如果不能返回前一个*/
        fun(num);/*递归调用*/
        vis[i]=true;/*返回递归的一个退出条件*/
    }
}


 


代码如下:

 

 

#include<stdio.h>
#include<string.h>
#include<stdbool.h>
int n;
bool vis[25];
int num[25];
bool fun(int s)
{
    for(int i=2; i*i<=s; i++)
    {
        if(s%i==0)
            return false;
    }
    return true;
}
void Dfs(int s,int t)//s第t-1个数的值  t要搜索第t个数
{
    if(t==n+1)//跳出的条件
    {
        if(fun(s+1)==true)
        {
            for(int i=1; i<n; i++)
            {
                printf("%d ",num[i]);
            }
            printf("%d\n",num[n]);
        }
        return ;
    }
    for(int i=1; i<=n; i++)//递归调用
    {
        if(vis[i]==false)//判断是否重复出现
        {
            if(fun(i+s)==true)
            {
                num[t]=i;
                vis[i]=true;
                Dfs(i,t+1);
                vis[i]=false;//进入到最深层后,返回时用到
            }
        }
    }
}
int main()
{
    int Case=0;
    while(~scanf("%d",&n))
    {
        printf("Case %d:\n",++Case);
        memset(vis,0,sizeof(vis));
        vis[1]=true;//确定这个数字使用过
        num[1]=1;//输出的数字
        Dfs(1,2);
        printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值