POJ 2105 IP Address

IP Address

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 38   Accepted Submission(s) : 22
Problem Description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are: 
27   26  25  24  23   22  21  20 

128 64  32  16  8   4   2   1 

 

Input
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.
 

Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.
 

Sample Input
  
  
4 00000000000000000000000000000000 00000011100000001111111111111111 11001011100001001110010110000000 01010000000100000000000000000001
 

Sample Output
  
  
0.0.0.0 3.128.255.255 203.132.229.128 80.16.0.1
 

Source
PKU
 



注意:有时候会报错 把int i定义到while函数外面

#include<stdio.h>
#include<string.h>
#include<math.h>
int main ()
{
    int n;

    scanf("%d",&n);
    getchar();//这个语句如果放在while里面 则第二次的循环过程的程序有影响
    while(n--)
    {
        char a[35];
        int b[35];
        int sum1=0,sum2=0,sum3=0,sum4=0;
        memset(b,0,sizeof(b));
        memset(a,'0',sizeof(a));
          int i;
        gets(a);
        for(i=0; i<=31; i++)
        {
            b[i]=a[i]-'0';
        }
        for(i=0; i<=7; i++)
        {
            if(b[i]==1)
            {
                sum1=sum1+pow(2,7-i);
            }
        }
        for(i=8; i<=15; i++)
        {
            if(b[i]==1)
            {
                sum2=sum2+pow(2,15-i);
            }
        }
        for(i=16; i<=23; i++)
        {
            if(b[i]==1)
            {
                sum3=sum3+pow(2,23-i);
            }
        }
        for(i=24; i<=31; i++)
        {
            if(b[i]==1)
            {
                sum4=sum4+pow(2,31-i);
            }
        }
        printf("%d.%d.%d.%d\n",sum1,sum2,sum3,sum4);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值