hdu2686 Matrix(dp)

0 篇文章 0 订阅

Matrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2378    Accepted Submission(s): 1257


Problem Description
Yifenfei very like play a number game in the n*n Matrix. A positive integer number is put in each area of the Matrix.
Every time yifenfei should to do is that choose a detour which frome the top left point to the bottom right point and than back to the top left point with the maximal values of sum integers that area of Matrix yifenfei choose. But from the top to the bottom can only choose right and down, from the bottom to the top can only choose left and up. And yifenfei can not pass the same area of the Matrix except the start and end. 
 

Input
The input contains multiple test cases.
Each case first line given the integer n (2<n<30) 
Than n lines,each line include n positive integers.(<100)
 

Output
For each test case output the maximal values yifenfei can get.
 

Sample Input
  
  
2 10 3 5 10 3 10 3 3 2 5 3 6 7 10 5 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7 4 5 6 7 8 5 6 7 8 9
 

Sample Output
  
  
28 46 80
 


题目来源:http://acm.split.hdu.edu.cn/showproblem.php?pid=2686

题目意思: 给一个n*n的矩阵给你,让你求两条路从(1,1)到(n,n)能取得最大权值(两条路不能相交).....

题目思路:https://www.51nod.com/tutorial/course.html#!courseId=11    (感觉这个讲得挺好的,就不讲了,一样的题目(只不过一个可以相交,一个不可以相交))。


代码如下:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 35;

int Max(int a, int b, int c, int d){
    a = max(a, b);
    b = max(c, d);
    return max(a, b);
}

int n;
int matrix[maxn][maxn];
int dp[maxn*2][maxn][maxn];

int main(){
    int step, x1, x2;
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                scanf("%d", &matrix[i][j]);
        memset(dp, 0, sizeof(dp));
        for(step = 1; step <= n*2-2; step++)
            for(x1 = 1; x1 <= step+1 && x1 <= n; x1++)
                for(x2 = 1; x2 <= step+1 && x2 <= n; x2++){
                    if(x1 == x2) continue;
                    dp[step][x1][x2] = Max(dp[step-1][x1][x2], dp[step-1][x1-1][x2], dp[step-1][x1-1][x2-1], dp[step-1][x1][x2-1]) + matrix[x1][step-x1+1] + matrix[x2][step-x2+1];
                }
        int ans = max(dp[step-1][n][n-1], dp[step-1][n-1][n]) + matrix[n][n];
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值