HDU 2686 Matrix(最大费用流)

Matrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1890    Accepted Submission(s): 1005


Problem Description
Yifenfei very like play a number game in the n*n Matrix. A positive integer number is put in each area of the Matrix.
Every time yifenfei should to do is that choose a detour which frome the top left point to the bottom right point and than back to the top left point with the maximal values of sum integers that area of Matrix yifenfei choose. But from the top to the bottom can only choose right and down, from the bottom to the top can only choose left and up. And yifenfei can not pass the same area of the Matrix except the start and end.
 

Input
The input contains multiple test cases.
Each case first line given the integer n (2<n<30)
Than n lines,each line include n positive integers.(<100)
 

Output
For each test case output the maximal values yifenfei can get.
 

Sample Input
  
  
2 10 3 5 10 3 10 3 3 2 5 3 6 7 10 5 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7 4 5 6 7 8 5 6 7 8 9
 

Sample Output
  
  
28 46 80
 

Author
yifenfei
 

Source
 题意:给一个n*n的距阵,每个点都有一个值。问从(0,0)到(n-1, n-1)点(只能从左到右 或 从上到下)再回到(0,0)点(只能从右到左 或 下到上)经过的点的值总和最大是多少?每个点只能走一次。
解题:其实就是找两条从(0,0)到(n-1,n-1)总和最大的路.拆点法。每个边容量为1,费用:对于点的本身,边权为点权,非点的边权值为0。
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN = 10010;
const int MAXM = 1001000;
const int INF = 1<<30;
struct EDG{
    int to,next,cap,flow;
    int cost;  //单价
}edg[MAXM];
int head[MAXN],eid;
int pre[MAXN], cost[MAXN] ; //点0~(n-1)

void init(){
    eid=0;
    memset(head,-1,sizeof(head));
}
void addEdg(int u,int v,int cap,int cst){
    edg[eid].to=v; edg[eid].next=head[u]; edg[eid].cost = cst;
    edg[eid].cap=cap; edg[eid].flow=0; head[u]=eid++;

    edg[eid].to=u; edg[eid].next=head[v]; edg[eid].cost = -cst;
    edg[eid].cap=0; edg[eid].flow=0; head[v]=eid++;
}

bool inq[MAXN];
bool spfa(int sNode,int eNode , int n){
    queue<int>q;
    for(int i=0; i<n; i++){
        inq[i]=false; cost[i]= -1;
    }
    cost[sNode]=0; inq[sNode]=1; pre[sNode]=-1;
    q.push(sNode);
    while(!q.empty()){
        int u=q.front(); q.pop();
        inq[u]=0;
        for(int i=head[u]; i!=-1; i=edg[i].next){
            int v=edg[i].to;
            if(edg[i].cap-edg[i].flow>0 && cost[v]<cost[u]+edg[i].cost){ //在满足可增流的情况下,最小花费
                cost[v] = cost[u]+edg[i].cost;
                pre[v]=i;   //记录路径上的边
                if(!inq[v])
                    q.push(v),inq[v]=1;
            }
        }
    }
    return cost[eNode]!=-1;    //判断有没有增广路
}
//反回的是最大流,最小花费为minCost
int minCost_maxFlow(int sNode,int eNode ,int& minCost , int n){
    int ans=0;
    while(spfa(sNode,eNode , n)){

        for(int i=pre[eNode]; i!=-1; i=pre[edg[i^1].to]){
            edg[i].flow+=1; edg[i^1].flow-=1;
            minCost+=edg[i].cost;
        }
        ans++;
        if(ans==2)break;
    }
    return ans;
}
int main(){
    int n,mapt[35][35];
    while(scanf("%d",&n)>0){
        init();
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            scanf("%d",&mapt[i][j]);
        int s = 0 , t = n*n-1;

        for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
        if(i||j){
            addEdg(i*n+j , i*n+j+n*n , 1 , mapt[i][j]);
            if(j+1<n) addEdg(i*n+j+n*n, i*n+j+1 , 1 , 0 );
            if(i+1<n) addEdg(i*n+j+n*n, (i+1)*n+j , 1 , 0);
        }
        else{
            addEdg(s , 1 , 1,0) , addEdg(s , n , 1 , 0);
        }
        int maxCost=mapt[0][0];
        if(n>1) maxCost+=mapt[n-1][n-1];
        minCost_maxFlow(s , t , maxCost , n*n*2);
        printf("%d\n",maxCost);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值