uva10474 (二分查找)

uva10474 (二分查找)

10474

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1…2…3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smart kid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.

output

For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1,2,…,N.
• ‘x not found’, if the marble with number x is not present. Look at the output for sample input for details.

sample intput

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

sample output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3


个人感想

 • 其实这算是uva中很简单的一道题,只是用到了排序和二分查找。
 • 题目意思就是给出两个数m和n下面输入m个数,再依次输入n个数,查找n个数在前面的m个数中是第几大。
   例如:sample 1 排序后: 1 2 3 5 , 5为第4大。
        sample 2 排序后: 1 1 3 3 3 , 3为第三大。(并不是第二大,因为本题1不重叠)

代码

#include<iostream>
#include<algorithm>
#define maxn 10010
using namespace std;

int num[maxn];
int num1[maxn];

int search(int begin,int end,int a)
{
    int m;
    while(begin<end)
    {
        m=begin+(end-begin)/2;
        if(num[m]>=a)end=m;
        else begin=m+1;
    }
    return num[begin]==a? begin:-1;
}

int main()
{
    int n1,n2;
    int A=0;
    while(cin>>n1>>n2)
    {
        A++;
        if(n1==0&&n2==0)break;
        for(int i=0;i<n1;i++)
            cin>>num[i];
        for(int i=0;i<n2;i++)
            cin>>num1[i];
        sort(num,num+n1);
        cout<<"CASE# "<<A<<":"<<endl;
        for(int i=0;i<n2;i++)
        {
            int m=search(0,n1-1,num1[i]);
            if(-1==m)cout<<num1[i]<<" not found"<<endl;
            else cout<<num1[i]<<" found at "<<m+1<<endl;
        }
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值