HDOJ1482 & POJ1013

Problem Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 

Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 

By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings. 

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A-L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1

ABCD EFGH even

ABCI EFJK up

ABIJ EFGH even

Sample Output

K is the counterfeit coin and it is light.

代码如下

#include <iostream>
#include <cstring>
using namespace std;

char Left[3][7];  //存放左边硬币
char Right[3][7];  //存放右边硬币
char Result[3][7];  //存放结果
bool IsFake(char c,bool light);   //判断函数
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        for(int i=0;i<3;i++)
        {
            cin>>Left[i]>>Right[i]>>Result[i];   //输入三次比较的数据
        }
        for(char c='A';c<='L';c++)
        {
            if(IsFake(c, true))
            {
                cout<<c<<" is the counterfeit coin and it is light."<<endl;
                break;
            }
            else if(IsFake(c, false))
            {
                cout<<c<<" is the counterfeit coin and it is heavy."<<endl;
                break;
            }
        }
    }
    return 0;
}
bool IsFake(char c,bool light)
{
    for(int i=0;i<3;i++)
    {
        char *pLeft,*pRight;
        if(light)        //如果假币更轻 如果up 则假币在右边 如果down 假币在左边
        {               //如果假币更重  如果up 则假币在左边  如果down 假币在右边
            pLeft=Left[i];  //因此为了少写代码  进行了一个变换  使得假币无论更轻更重  只要up 假币都在右边
            pRight=Right[i];
        }
        else{
            pRight=Left[i];
            pLeft=Right[i];
        }
        switch(Result[i][0])
        {
            case 'u':
                if(strchr(pRight,c)==NULL)        //up 则假币在右边
                    return false;
                break;
            case 'e':
                if(strchr(pRight,c) || strchr(pLeft,c))
                    return false;
                break;
            case 'd':
                if(strchr(pLeft,c)==NULL)  //down 则假币在左边
                    return false;
                break;
        }
    }
    return true;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值