hdu6154

CaoHaha's staff

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 49


Problem Description
"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.
 

Input
The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).
 

Output
Out put T integer in each line ,the least time CaoHaha can send the toy.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
4 4 6 6 7
 

题意:一个个边长为1的正方形可分为两个正方形,在坐标轴中连单位正方形的边或斜边,找出能包含n个正方形面积的最小边数。

思路:先打表把边数为x的能包含的最多碎片正方形求出来(遇到边数为4的倍数的边数就直接为斜的正方形,公式出里面包含的碎片正方形个数,再通过这个来求其他三种情况,每次把两条斜的边改为竖直和水平)。


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double d[1000005];
void init()
{
	for(int i=0;i<4;i++)d[i]=0;
	d[4]=2;
	d[5]=2.5;
	d[6]=4;
	d[7]=5.5;
	for(int i=8;i<1000000;i=i+4)
	{
		d[i]=((double)i*i)/8;
		d[i+1]=d[i]+(double)(i-2)/4;
		d[i+2]=d[i+1]+(double)(i-2)/4+1;
		d[i+3]=d[i+2]+(double)(i-2)/4+1;
	}
//	for(int i=0;i<100;i++)cout<<d[i]<<endl;
}

int main()
{
	int t;
	scanf("%d",&t);
	init();
	while(t--)
	{
		int n;
		scanf("%d",&n);
//		printf("%lf\n",d[n]);
		printf("%d\n",lower_bound(d,d+100000,n)-d);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值