hdu6154CaoHaha's staff(2017网络赛规律)

CaoHaha's staff

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 562    Accepted Submission(s): 333


Problem Description
"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.
 

Input
The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).
 

Output
Out put T integer in each line ,the least time CaoHaha can send the toy.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
4 4 6 6 7
 

Source

计算出用面积为n的图最少要多少段线段才能画,画线只能画对角线和坐标方向,可以想象成方格里面有很多小方格,每个小方格面积为1,这样第一次画4条线段时用四条对角线则能画出最大面积√2* √2=2,五条线时则相当于变成了五边形,多了一个小三角线,面积为2+0.5=2.5,
六条线时,则在原四边形上加上一个四边形,2+2=4面积最大化,七条边时,在六边形形成的情况下,去掉两条边,在矩形上面形成一个梯形,则面积最大,面积为4+3=7,八条线时,面积最大则为两个六边形形成的大正方形,面积为8,由此得出规律:
/**
   by z_guibin
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
#define N 100005
double dp[N];
void solve()
{
    double x=0.5,y=2;
    dp[4]=2;


    for(int i=5; i<=N; i++)
    {
        if(i%4==1)
            dp[i]=dp[i-1]+x,x+=1.0;
        else if(i%4==2)
            dp[i]=dp[i-2]+y,y+=2.0;
        else if(i%4==3)
            dp[i]=dp[i-1]+x;
        else if(i%4==0)
            dp[i]=dp[i-2]+y;
    }
}
int main()
{
    double n;
    solve();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cin>>n;




        for(int i=4; i<=N; i++)
        {
            if(dp[i]>=n)
            {
                cout<<i<<endl;
                break;
            }
        }


    }
    return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值