hdu2588(欧拉函数)

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2461    Accepted Submission(s): 1271


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int d[2][100005];
int n,m;

int Euler(int n)

{

    int ret=n;

    for(int i=2;i<=sqrt(n);i++)

     if(n%i==0)

      {

        ret=ret/i*(i-1);//先进行除法防止溢出(ret=ret*(1-1/p(i)))

        while(n%i==0)

          n/=i;

     }

    if(n>1)

          ret=ret/n*(n-1);

        return ret;

}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		int ans=0;
		/*
		这个x必定为n的因子,遍历n的大于m因子i,找出n除以这个因子部分的欧拉函数,则找出了与n的最大公约数为i的数的个数 
		*/
		for(int i=1;i*i<=n;i++)
		{
			if(n%i)continue;
			if(i>=m&&i*i<n)       //求出这个以这个因子为最大公约数的数的个数 
			{
				ans+=Euler(n/i);
			}
			if(n/i>=m)            //(n/i)*(n/i)>=n,求出这个因子为最大公约数的数的个数 
			{
                ans+=Euler(i);
            }
		}
		printf("%d\n",ans);
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值