hdu 2588

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1668    Accepted Submission(s): 807


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
 

这道题所需要的算法主要为欧拉函数的运用和一点点的GCD知识。

问题所要求的是 gcd( x , n ) > m ,由gcd( x , n )本身可知,gcd求出来的是 x 和n的最大公约数(设为a),即有式子gcd( x ,n )=a , 进一步进行化简可变为gcd( x/a , n/a )=1 , 到了此处这个式子又有了另一层含义——x/a与n/a互素 。在联想到欧拉函数的功能——对正整数n,欧拉函数是小于或等于n的数中与n互质的数的数目。于是将欧拉函数里的n换成n/a,不就正好能求出x/a的个数了吗?x/a的个数不就是我们所要求的x的个数了吗?

#include <iostream>
#include <math.h>
using namespace std;

int oula(int n)
{
    int i,ret=n;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            ret=ret-ret/i;
            while(n%i==0) n/=i;
        }
    }
    if(n>1) ret=ret-ret/n;
    return ret;
}
int main()
{
    long long int i,n,m,sum,t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        sum=0;
        if(m==1)
        {
            cout<<n<<endl;
            continue;
        }
        for( i=2;i*i<=n;i++)
        {
            if(n%i==0)
            {
                if(i>=m)
                sum=sum+oula(n/i);
                if(n/i>=m)
                sum=sum+oula(i);
            }
        }
        int sqn=sqrt(n+0.5);
        if(sqn*sqn==n&&sqn>=m)
        sum=sum-oula(sqn);
        cout<<sum+1<<endl;
    }
    //cout << "Hello world!" << endl;`
    return 0;
}
PS:引用i*i是为了缩减代码复杂度,否则会超时,最后的减去是为了减去重复的一项。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值