Let S be a sequence of integers s1, s2, ..., sn Each integer is is associated with a weight by the following rules:
(1) If is is negative, then its weight is 0.
(2) If is is greater than or equal to 10000, then its weight is 5. Furthermore, the real integer value of si is si−10000 . For example, if si is 10101, then is is reset to 101 and its weight is 5.
(3) Otherwise, its weight is 1.
A non-decreasing subsequence of S is a subsequence si1, si2, ..., sik, with i1<i2 ... <ik, such that, for all 1≤j<k, we have sij<sij+1.
A heaviest non-decreasing subsequence of S is a non-decreasing subsequence with the maximum sum of weights.
Write a program that reads a sequence of integers, and outputs the weight of its
heaviest non-decreasing subsequence. For example, given the following sequence:
80 75 73 93 73 73 10101 97 −1 −1 114 −1 10113 118
The heaviest non-decreasing subsequence of the sequence is <73,73,73,101,113,118> with the total weight being 1+1+1+5+5+1=14. Therefore, your program should output 14 in this example.
We guarantee that the length of the sequence does not exceed 2∗105
Input Format
A list of integers separated by blanks:s1, s2,...,sn
Output Format
A positive integer that is the weight of the heaviest non-decreasing subsequence.
样例输入
80 75 73 93 73 73 10101 97 -1 -1 114 -1 10113 118
样例输出
14
题目来源
先把数值转换,然后把weight转换为连续出现次数,套用最长非递减子序列模板。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=1000010;
int data[maxn];
int maxv[maxn];
int BinaryResearch(int x,int len)
{
int mid,low=1,high=len;
while(low<=high)
{
mid=(low+high)>>1;
if(maxv[mid]<=x)
{
low=mid+1;
}
else high=mid-1;
}
return low;
}
int lis(int n)
{
int i,len=1;
maxv[1]=data[0];
for(i=1;i<n;i++)
{
if(data[i]>=maxv[len])
{
maxv[++len]=data[i];
}
else
{
int pos=BinaryResearch(data[i],len);
maxv[pos]=data[i];
}
}
return len;
}
int main()
{
memset(data,0,sizeof(data));
memset(maxv,0,sizeof(maxv));
int len=0;
int x;
while(scanf("%d",&x)!=EOF)
{
if(x<0)continue;
else if(x>=10000)
{
x=x-10000;
data[len++]=x;
data[len++]=x;
data[len++]=x;
data[len++]=x;
data[len++]=x;
}
else
{
data[len++]=x;
}
}
printf("%d\n",lis(len));
}