计蒜客 The Heaviest Non-decreasing Subsequence Problem(最大权值和非递减子序列)

Let SS be a sequence of integers s_{1}s1s_{2}s2......s_{n}sn Each integer is is associated with a weight by the following rules:

(1) If is is negative, then its weight is 00.

(2) If is is greater than or equal to 1000010000, then its weight is 55. Furthermore, the real integer value of s_{i}si is s_{i}-10000si10000 . For example, if s_{i}si is 1010110101, then is is reset to 101101 and its weight is 55.

(3) Otherwise, its weight is 11.

A non-decreasing subsequence of SS is a subsequence s_{i1}si1s_{i2}si2......s_{ik}sik, with i_{1}<i_{2}\ ...\ <i_{k}i1<i2 ... <ik, such that, for all 1 \leq j<k1j<k, we have s_{ij}<s_{ij+1}sij<sij+1.

A heaviest non-decreasing subsequence of SS is a non-decreasing subsequence with the maximum sum of weights.

Write a program that reads a sequence of integers, and outputs the weight of its

heaviest non-decreasing subsequence. For example, given the following sequence:

8080 7575 7373 9393 7373 7373 1010110101 9797 -11 -11 114114 -11 1011310113 118118

The heaviest non-decreasing subsequence of the sequence is <73, 73, 73, 101, 113, 118><73,73,73,101,113,118> with the total weight being 1+1+1+5+5+1 = 141+1+1+5+5+1=14. Therefore, your program should output 1414 in this example.

We guarantee that the length of the sequence does not exceed 2*10^{5}2105

Input Format

A list of integers separated by blanks:s_{1}s1s_{2}s2,......,s_{n}sn

Output Format

A positive integer that is the weight of the heaviest non-decreasing subsequence.

样例输入
80 75 73 93 73 73 10101 97 -1 -1 114 -1 10113 118
样例输出
14
题目来源

2017 ACM-ICPC 亚洲区(南宁赛区)网络赛


先把数值转换,然后把weight转换为连续出现次数,套用最长非递减子序列模板。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=1000010;
int data[maxn];
int maxv[maxn];
int BinaryResearch(int x,int len)
{
	int mid,low=1,high=len;
	while(low<=high)
	{
		mid=(low+high)>>1;
		if(maxv[mid]<=x)
		{
			low=mid+1;
		}
		else high=mid-1;
	}
	return low;
}
int lis(int n)
{
	int i,len=1;
	maxv[1]=data[0];
	for(i=1;i<n;i++)
	{
		if(data[i]>=maxv[len])
		{
			maxv[++len]=data[i];
		}
		else
		{
			int pos=BinaryResearch(data[i],len);
			maxv[pos]=data[i];
		}
	}
	return len;
}
int main()
{
	memset(data,0,sizeof(data));
	memset(maxv,0,sizeof(maxv));
	int len=0;
	int x;
	while(scanf("%d",&x)!=EOF)
	{
		if(x<0)continue;
		else if(x>=10000)
		{
			x=x-10000;
			data[len++]=x;
			data[len++]=x;
			data[len++]=x;
			data[len++]=x;
			data[len++]=x;
		}
		else
		{
			data[len++]=x;
		}
	}
	printf("%d\n",lis(len));
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值