POJ—2153(STL<map>)

3 篇文章 0 订阅
3 篇文章 0 订阅


C - STL之<map>
Time Limit:10000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2
题意: 给出李明和他们班同学的每次考试的成绩,问每次考试后李明在班内的排名,排名是按总分数。(累计成绩)
分析:使用STL<map>,形成成绩和姓名之间的映射。不需要排序,只要知道李明现在的排名即可,初始排名第一,
如果有人成绩比他
就rank++;
#include <iostream>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
#define N 102
map<string,int>stu;///名字和成绩的映射
map<string,int>::iterator it;
int main()
{
	int score,n,m,rank;
	char name[N];
	while(~scanf("%d",&n))
	{
	    getchar();
        for(int i=0;i<n;i++)
        {
            gets(name);//scanf("%s",name);
            stu[name]=0;///名字对应成绩先初始化为0
        }
		scanf("%d",&m);///考试数目
		for(int i=0;i<m;i++)
		{
			rank=1;///记录李明的名次,每场考试都要刷新
			for(int j=0;j<n;j++)
			{
				scanf("%d",&score);
				getchar();
				gets(name);
				stu[name]+=score;///总分的成绩,排名每次都要+
			}
			for(it=stu.begin();it!=stu.end();it++)///map
			{
				 if(it->second>stu["Li Ming"]) rank++;///如果有人成绩比他高,排名+1
			}
			printf("%d\n",rank);///输出排名
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值