uva—benefit

3 篇文章 0 订阅
2 篇文章 0 订阅


  Benefit 

Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer T ( T$ \le$100000), the number of tests. Each test that comes in a separate line contains two integers A and C ( 1$ \le$A, C$ \le$107).

Output 

Print the lowest integer B such that LCM(A, B) = C in a single line. If no such integer exists, print " NO SOLUTION" instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION
题意:给出A,C,A是其中一个数,C是lcm,求另一个数B,即A和B的最小公倍数是C。没有输出“NO SOLUTION”

解析:先判断有没有解,若是C%A!=0,cout<<"NO SOLUTION"<<endl;否则如下:

           lcm=A*B/gcd(A,B);所以当我们直接拿C/A,得到的数比B少了gcd,因此要乘回去。

           B=B'*gcd(A,B);gcd(A,B)是一个常数t,因此有B=t*B';

           B=B'*gcd(A,t*B‘),t=gcd(A,t*B')

           如何求t值——通过不断“吸取”A中的A和B'的公约数来实现这一点

            b=c/a;
            t=gcd(a,b);
            while(t!=1){
                b*=t;
                a/=t;
                t=gcd(a,b);
            }
代码:

#include <iostream>
#include <cstdio>
using namespace std;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int a,b,c,t;
        cin>>a>>c;
        if(c%a!=0)
            cout<<"NO SOLUTION"<<endl;
        else{
            b=c/a;
            t=gcd(a,b);
            while(t!=1){
                b*=t;
                a/=t;
                t=gcd(a,b);
            }
            cout<<b<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值