05-树8 File Transfer

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?
Input Specification:

Each input file contains one test case. For each test case, the first line contains NN (2\le N\le 10^42≤N≤10
​4
​​ ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and NN. Then in the following lines, the input is given in the format:
I c1 c2
where I stands for inputting a connection between c1 and c2; or
C c1 c2
where C stands for checking if it is possible to transfer files between c1 and c2; or
S
where S stands for stopping this case.
Output Specification:

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.
Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:

no
no
yes
There are 2 components.
Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:

no
no
yes
yes
The network is connected.

题目大意:判断两台电脑是否连通,并判断电脑间是否相互连通,否则输出最大连通数目

思路:可以通过集合来解决这道题。利用判断两台电脑是否在同一集合里,若是则连通,否则不连通。

#include<iostream>  
using namespace std;

int *s;
int FindRoot(int x)
{
    if (s[x] == x)
        return x;
    else
        s[x] = FindRoot(s[x]);
}

void Union(int a, int b)
{
    int root1, root2;
    root1 = FindRoot(a);      //找根  
    root2 = FindRoot(b);
    if (root1 != root2){
        if (s[root1]<s[root2])
            s[root2] = root1;
        else
            s[root1] = root2;
    }
}

int main()
{
    int i, N, num1, num2, count = 0;
    char ch;
    cin >> N;
    s = new int[N + 1];
    for (i = 0; i <= N; i++){
        s[i] = i;
    }
    while (1){
        cin >> ch;
        if (ch == 'S')
            break;
        cin >> num1 >> num2;
        if (ch == 'I')
            Union(num1, num2);
        if (ch == 'C'){
            if (FindRoot(num1) == FindRoot(num2))
                cout << "yes" << endl;
            else
                cout << "no" << endl;
        }
    }
    for (i = 1; i <= N; i++){
        if (s[i] == i)
            count++;
    }
    if (count == 1)
        cout << "The network is connected." << endl;
    else
        cout << "There are " << count << " components." << endl;
    delete[] s;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值