05-树9 Huffman Codes

In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.
Input Specification:

Each input file contains one test case. For each case, the first line gives an integer NN (2\le N\le 632≤N≤63), then followed by a line that contains all the NN distinct characters and their frequencies in the following format:
c[1] f[1] c[2] f[2] … c[N] f[N]
where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer MM (\le 1000≤1000), then followed by MM student submissions. Each student submission consists of NN lines, each in the format:
c[i] code[i]
where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 ‘0’s and ‘1’s.
Output Specification:

For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.
Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.
Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11
Sample Output:

Yes
Yes
No
No

题目大意:判断给出的哈夫曼编码是否正确

思路:不用重新构建哈夫曼编码,因为可能有数种情况,只要比较其花费是否最小,编码是否出现前序重复就可以了。

#include<iostream>
#include<functional>
#include <string>  
#include <algorithm>  
#include <queue>  
using namespace std;

typedef struct{
    char alpha;
    int frequency;
}inputdata;

typedef struct{
    char alpha;
    string code;
}check;

int getfrequency(char alpha,inputdata* data,int num)
{
    for (int i = 0; i < num; i++)
    {
        if (data[i].alpha == alpha)
            return data[i].frequency;
    }
    return 0;
}

bool cmp(check ch1, check ch2)
{
    return ch1.code.size() < ch2.code.size();
}

bool isoverlap(check* ch,int num)
{
    sort(ch, ch + num, cmp);
    for (int i = 0; i < num; i++)
    {
        string tmp = (ch + i)->code;
        for (int j = i + 1; j < num; j++)
        {
            if ((ch + j)->code.substr(0, tmp.size()) == tmp)
                return true;
        }
    }
    return false;
}

int main()
{
    int num;
    cin >> num;

    int leastcost = 0;
    inputdata* input = new inputdata[num];
    priority_queue<int, vector<int>, greater<int>> q;
    for (int i = 0; i < num; i++)
    {
        cin >> (input + i)->alpha;
        cin >> (input + i)->frequency;
        q.push((input + i)->frequency);
    }
    int sum;
    while (!q.empty())
    {
        sum = 0;
        sum += q.top();
        q.pop();
        if (!q.empty())
        {
            sum += q.top();
            q.pop();
            q.push(sum);
        }

        leastcost += sum;

    }

    int N;
    cin >> N;

    int cost;
    int* flag = new int[N];
    check* temp = new check[num];
    for (int i = 0; i < N; i++)
    {
        cost = 0;
        for (int j = 0; j < num; j++)
        {
            cin >> (temp + j)->alpha;
            cin >> (temp + j)->code;
        }

        for (int j = 0; j < num; j++)
        {
            cost += (temp[j].code.size()+1)*getfrequency(temp[j].alpha, input, num);
        }

        if (cost>leastcost)
        {
            //flag[i] = 0;
            printf("No\n");
        }
        else
        {
            if (isoverlap(temp, num))
                //flag[i] = 0;
                printf("No\n");
            else
                //flag[i] = 1;
                printf("Yes\n");
        }

    }


    delete[]flag;
    delete[]input;
    delete[]temp;



    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值