HDU 5159 Card(数学期望)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5159


Card

 
Problem Description
There are x cards on the desk, they are numbered from 1 to x. The score of the card which is numbered i(1<=i<=x) is i. Every round BieBie picks one card out of the x cards,then puts it back. He does the same operation for b rounds. Assume that the score of the j-th card he picks is  Sj  . You are expected to calculate the expectation of the sum of the different score he picks.
 

Input
Multi test cases,the first line of the input is a number T which indicates the number of test cases. 
In the next T lines, every line contain x,b separated by exactly one space.

[Technique specification]
All numbers are integers.
1<=T<=500000
1<=x<=100000
1<=b<=5
 

Output
Each case occupies one line. The output format is Case #id: ans, here id is the data number which starts from 1,ans is the expectation, accurate to 3 decimal places.
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 3
 

Sample Output
  
  
Case #1: 2.625 Case #2: 4.222
Hint
For the first case, all possible combinations BieBie can pick are (1, 1, 1),(1,1,2),(1,2,1),(1,2,2),(2,1,1),(2,1,2),(2,2,1),(2,2,2) For (1,1,1),there is only one kind number i.e. 1, so the sum of different score is 1. However, for (1,2,1), there are two kind numbers i.e. 1 and 2, so the sum of different score is 1+2=3. So the sums of different score to corresponding combination are 1,3,3,3,3,3,3,2 So the expectation is (1+3+3+3+3+3+3+2)/8=2.625

题意:

             X张卡牌,标号分别为1,2,…,X,,每张牌的分数为对应的序号,随机抽取卡牌b次,每次都放回,记录下卡牌的分数,求抽取到不同卡牌的期望

思路:

    和的期望 = 各部分期望的和。

 E = E(1) + E(2) + ... + E(x) ;

 每张牌每一轮抽到的概率为 1/x ;

 每张牌每一轮不抽到的概率为 1-1/x ;

 每张牌b次操作后都没抽到的概率为 (1-1/x)^b ;

 每张牌b次操作后有被抽到的概率为 p = 1-(1-1/x)^b ;

 所以每个数的期望也是 i*( 1-(1-1/x)^b )


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int t,k=1;
    scanf("%d",&t);
    double x,b;
    while(t--)
    {
        scanf("%lf%lf",&x,&b);
        double ans=0;
        double p=1-pow((1-1.0/x),b);
        double n=(1+x)*x*1.0/2;
        ans=n*p;
        printf("Case #%d: %.3lf\n",k++,ans);
    }
    return 0;
}


































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值