POJ3278抓牛 bfs:队列+struct

农夫John得知一头逃犯奶牛的位置,他从点N开始沿着数轴追赶,奶牛位于点K。他有两种移动方式:步行和瞬移。步行可以向左或向右移动一单位,瞬移可以移动到当前位置的两倍。若奶牛不动,求John最快多久能抓住它。输入包含两个整数N和K,输出是最少时间。例如,当N=5, K=17时,最短路径为5-10-9-18-17,需要4分钟。" 119857996,8414914,手动调整ESXi网卡名称,"['虚拟化技术', 'ESXi配置', '网络管理']
摘要由CSDN通过智能技术生成

B - 抓牛 POJ - 3278

自用
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
郭炜老师的代码,十分清晰,其中结构体的最后一句是为了便于初始化

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
int N,K;
int MAXN = 100000;
int mk[100010];
struct step{
	int x;
	int steps;
	step(int xx,int s):x(xx),steps(s){
	}
};
queue<step> q;
int main() {
	cin>>N>>K;
	memset(mk,0,sizeof(mk));
	q.push(step(N,0));
	mk[N] = 1;
	while(!q.empty()){
		step s = q.front();
		if(s.x == K){
			cout<<s.steps<<endl;
			return 0;
		}
		else{
			if(s.x -1 >= 0&&!mk[s.x-1]){
				q.push(step(s.x-1,s.steps+1));
				mk[s.x-1] = 1;
			}
			if(s.x +1 <= MAXN&&!mk[s.x+1]){
				q.push(step(s.x+1,s.steps+1));
				mk[s.x+1] = 1;
			}
			if(s.x *2 <= MAXN&&!mk[s.x*2]){
				q.push(step(s.x*2,s.steps+1));
				mk[s.x*2] = 1;
			}
			q.pop();
		}
	}
	return 0;
}

GQ学长细心的解释:
在这里插入图片描述
总结:最近一个月学习的状态十分不好,不能让gqg在问我的时候那么令人失望。。。。Orz

  • 周末之前,搞定WORD**“算法很美”**
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值