POJ 1979 Red and Black DFS水题

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31119 Accepted: 16977

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source


    题意:输入地图,@为起点,.可以走,#不可以走,求出可以走到的区域点数,包括@。

    分析:DFS水题。设置全局变量res时注意要清零。见AC代码:

#include<stdio.h>
#include<string.h>
const int maxn=21;
char map[maxn][maxn];
int  vis[maxn][maxn];
int res=0;
int w,h;
int dx[4]= {0,0,-1,1};
int dy[4]= {-1,1,0,0};
void dfs(int x,int y)
{
	if(x<0||x>=h||y<0||y>=w)
		return;
	if(!vis[x][y]&&(map[x][y]=='.'||map[x][y]=='@'))
	{
		res++;
		vis[x][y]=1;
		//printf("++\n");
		for(int i=0; i<4; i++)
			dfs(x+dx[i],y+dy[i]);
	}
}
int main()
{
	while(~scanf("%d%d",&w,&h)&&w&&h)
	{
		res=0;
		memset(vis,0,sizeof(vis));
		for(int i=0; i<h; i++)
			scanf("%s",map[i]);
		int xs,ys;
		for(int i=0; i<h; i++)
			for(int j=0; j<w; j++)
				if(map[i][j]=='@')
				{
					xs=i;
					ys=j;
					break;
				}
		//printf("%d %d \n",xs,ys);
		dfs(xs,ys);
		printf("%d\n",res);
	}
}
    刷题时需细心仔细,避免无谓错误。DFS需要多刷。

    特记下,以备后日回顾。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值