Cable master 小数二分

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36054 Accepted: 7693

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

Northeastern Europe 2001

    该题使用二分法解决,但是需要注意精度。这精度……实在让人头疼。

    题意:有n根电线,你需要从中剪得k根同等长度的电线,现在求剪得电线的最大值。

    分析:逆向思维用最长长度去验证是否满足条件能剪得不小于k的根数。验证函数很容易理解,由于电线之间不可以拼接,所以每根电线长度/割成电线的长度即为此根电线可形成所求电线的根数,枚举即可得到最终可割个数。二分法判断在此不赘述。

    给出能在pojAC的代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=10005;
double a[maxn];
int n,k;
int check(double x)  //判断函数
{
	int num=0;
	for(int i=0; i<n; i++)
		num+=(int)a[i]/x;  //int 不可少
	if(num>=k) //大于等于是根据题意  要让结果尽可能大
		return 1;
	return 0;
}
int main()
{
	scanf("%d%d",&n,&k);
	for(int i=0; i<n; i++)
		scanf("%lf",&a[i]);
	sort(a,a+n); //排序确定 r的值 该题中 每根线的值不可能超过最大的电线长度
	double l=0,r=a[n-1],mid,res=0.00;
	while(r-l>=1e-15)  //精度
	{
		mid=(l+r)/2;
		double p=check(mid);
		if(p)
		{
			res=mid;  //注意更新答案
			l=mid;
		}
		else
			r=mid;
	}
	if((int)(res*1000)%10>=5)
		r-=0.005;
	printf("%.2lf\n",res);
}
    该题最为坑人的一点是,题目要求的结果是两位小数的,并不能单单地printf("%.2lf\n",res),这样是默认四舍五入的,举例:所得结果是3.457,题目要求的答案是3.45,而直接printf得到的是3.46!wa来wa去的……所以需要对最终的结果进行处理,乘以一千对10取余后若大于5则该种情况会四舍五入,原结果减去0.005即可。真是……

    该题花了很多时间,看来读题得谨慎,不能想当然。

    特记下,以备后日回顾。


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值