Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 17707 | Accepted: 5971 |
Description
Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
= = = = - = Cows facing right --> = = = = - = = = = = = = = = 1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Sample Input
6 10 3 7 4 12 2
Sample Output
5
用单调栈求出距离num[i]最近的大于等于num[i]的数num[j], 那么第i头牛可以看到j - i - 1头牛
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <stack>
#define INF 1e9
#define maxn 80005
using namespace std;
typedef long long ll;
int num[maxn];
stack<int> s;
int main(){
// freopen("in.txt", "r", stdin);
int n;
while(scanf("%d", &n) == 1){
while(!s.empty())
s.pop();
for(int i = 0; i < n; i++)
scanf("%d", num+i);
ll ans = 0;
for(int i = n-1; i >= 0; i--){
while(!s.empty() && num[s.top()] < num[i])
s.pop();
if(s.empty())
ans += n - 1 - i;
else
ans += s.top() - i - 1;
s.push(i);
}
printf("%I64d\n", ans);
}
return 0;
}