AtCoder Beginner Contest 177 B-Substring

在这里插入图片描述
在这里插入图片描述
Sample Input 1

cabacc
abc

Sample Output 1

1

Sample Input 2

codeforces
atcoder

Sample Output 2

6

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<time.h>
#include<vector>
using namespace std;
int main()
{
    //ios::sync_with_stdio(false);
    //cin.tie(0);
    //cout.tie(0);
    char s1[1005],s2[1005];
    scanf("%s",s1);
    scanf(" %s",s2);
    int len1 = strlen(s1);
    int len2 = strlen(s2);
    int ans = 1e8;
    for(int i=0; i+len2<=len1; ++i){  //枚举切割点
        int t = 0;
        //枚举不相等的个数
        for(int j=0; j<len2; ++j){
            if(s1[i+j]!=s2[j])
                t++;
        }
        ans = min(ans,t);
    }
    printf("%d\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

葛济维的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值