FZU Problem 1148 Crossed ladders

Problem 1148 Crossed ladders

Accept: 205 Submit: 398 Time Limit: 1000 mSec Memory Limit : 32768 KB

img Problem Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

img

img Input

Each line of input contains three positive floating point numbers giving the values of x, y, and c.

img Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

img Sample Input

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

img Sample Output

26.033

7.000

8.000

9.798

img Source

Albert 2001

解决方案

在这里插入图片描述

采用二分逼近方法求出D

#include <cstdio>
#include <cmath>
double x, y, c;
bool judge(double o)
{
	double tmp1 = sqrt(x*x - o * o);
	double tmp2 = sqrt(y*y - o * o);
	if (tmp1*tmp2 >= c * (tmp1 + tmp2))
	{
		return true;
	}
	else
	{
		return false;
	}
}
double min(double x, double y)
{
	return x < y ? x : y;
}
int main()
{
	while (scanf("%lf%lf%lf", &x, &y, &c)!=EOF)
	{
		
		double l = 0, r = min(x, y);//直角边不会大于斜边
		int size = 100;
		double mid;
		while (size--)
		{
			mid = (l + r) / 2.0;
			if (judge(mid))
			{
				l = mid;
			}
			else
			{
				r = mid;
			}
		}
		printf("%.3lf\n", mid);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值