POJ-1308 Is It A Tree?(并查集)

加油。
To be better.

题目链接:
https://cn.vjudge.net/problem/POJ-1308
题目:
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
在这里插入图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入:
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
输出:
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入:
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
样例输出:
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题目大意:
给你一组两两成对的数组,一个前驱,一个后继,判断是否是树。遇到0 0结束一组输入,遇到-1 -1结束输入。

题目解析:
本题可利用树的定义来做,在树中,每个节点都有唯一的后继,如果两个节点有一个共同的后继,那么它就不是树;边数=节点数+1

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 10000
using namespace std;
int f[maxn];
int vis[maxn];

void Init()
{
    for(int i=1; i<maxn; i++)
        f[i]=i;
}
int Find(int x)
{
    if(x==f[x])
        return x;
    else
        return Find(f[x]);
}
void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
    {
        f[x]=y;
    }
}

int main()
{
    int a,b,k=1,flag;
    memset(vis,0,sizeof(vis));
            Init();
    while(cin>>a>>b)
    {
        if(a<0&&b<0)
            break;
        else if(a==0&&b==0)
        {
            int first=0;
            for(int i=1;i<maxn;i++)
            {
                if(vis[i])
                {
                    first=i;
                    break;
                }
            }
            for(int i=1;i<maxn;i++)
            {
                if(vis[i]&&first&&Find(first)!=Find(i))
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
                printf("Case %d is a tree.\n",k++);
            else
                printf("Case %d is not a tree.\n",k++);
            memset(vis,0,sizeof(vis));
            Init();
            flag=1;
        }
        else
        {
            vis[a]=1;vis[b]=1;
            if(Find(a)==Find(b))flag=0;
            else Union(a,b);
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值