HDU-3336 Count the string(KMP+DP)

加油。
To be better.

题目链接:
https://cn.vjudge.net/problem/HDU-3336
题目:
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: " abab"
The prefixes are: “a”, " ab", " aba", " abab"
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, " ab" matches twice too, " aba" matches once, and " abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For " abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab
Sample Output
6

题目大意:
给你一个字符串,让你计算出所有非空子串在母串中出现的次数之和。

题解:
我原本以为这就是一个KMP的模板题,依次计算出子串的出现次数,然后求和,但是!!!无论我用C++交还是C交,都是TLE时间超限。所以我上网搜了资料,原来需要只需要求一遍母串的Next数组,之后进行动态规划即可!
核心公式:dp[i]=dp[net[i]]+1;
dp数组理解不是太清晰…
在这里插入图片描述
代码:

#include <iostream>
#include <cstring>
#define mod 10007
using namespace std;
const int maxn=200010;
string t;
int net[maxn],dp[maxn];
int tlen;

void GetNext()
{
    //求出模式串t的net数组值
    int j,k;//j扫描t,k记录t[j]之前与t开头相同的字符个数
    j=0,k=-1;
    net[0]=-1;
    while(j<tlen)
    {
        if(k==-1||t[j]==t[k])
        {
            j++,k++;//j,k依次移动到下一个字符
            net[j]=k;//设置next的值
        }
        else
            k=net[k];//k回溯
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    cin>>n;
    while(n--)
    {
        long long ans=0;
        memset(dp,0,sizeof(dp));
        cin>>tlen;
        cin>>t;
        GetNext();
        dp[0]=0;
        for(int i=1,j; i<=tlen; i++)
        {
            dp[i]=dp[net[i]]+1;
            ans=ans%mod+dp[i]%mod;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值