USACO 2.2 Preface Numbering

A certain book's prefaces are numbered in upper case Roman numerals. Traditional Roman numeral values use a single letter to represent a certain subset of decimal numbers. Here is the standard set:

I 1 L 50 M 1000
V 5 C 100
X 10 D 500
As many as three of the same marks that represent 10n may be placed consecutively to form other numbers:

III is 3
CCC is 300
Marks that have the value 5x10n are never used consecutively.

Generally (with the exception of the next rule), marks are connected together and written in descending order to form even more numbers:

CCLXVIII = 100+100+50+10+5+1+1+1 = 268
Sometimes, a mark that represents 10^n is placed before a mark of one of the two next higher values (I before V or X; X before L or C; etc.). In this case, the value of the smaller mark is SUBTRACTED from the mark it precedes:

IV = 4
IX = 9
XL = 40
This compound mark forms a unit and may not be combined to make another compound mark (e.g., IXL is wrong for 39; XXXIX is correct).
Compound marks like XD, IC, and XM are not legal, since the smaller mark is too much smaller than the larger one. For XD (wrong for 490), one would use CDXC; for IC (wrong for 99), one would use XCIX; for XM (wrong for 990), one would use CMXC. 90 is expressed XC and not LXL, since L followed by X connotes that successive marks are X or smaller (probably, anyway).

Given N (1 <= N < 3,500), the number of pages in the preface of a book, calculate and print the number of I's, V's, etc. (in order from lowest to highest) required to typeset all the page numbers (in Roman numerals) from 1 through N. Do not print letters that do not appear in the page numbers specified.

If N = 5, then the page numbers are: I, II, III, IV, V. The total number of I's is 7 and the total number of V's is 2.

PROGRAM NAME: preface

INPUT FORMAT

A single line containing the integer N.
SAMPLE INPUT (file preface.in)

5
OUTPUT FORMAT

The output lines specify, in ascending order of Roman numeral letters, the letter, a single space, and the number of times that letter appears on preface page numbers. Stop printing letter totals after printing the highest value letter used to form preface numbers in the specified set.
SAMPLE OUTPUT (file preface.out)

I 7

V 2


题目就是给定一个数n,统计1~n这些数转化为罗马数字表达方式后,每个字母的使用量。 

思路:找到罗马计数的规律,如下图,可以发现个、十、百、千位上计数法则都是一样的,只是表示的字母不同,且每一位上的数字表示只需用到三种字母,如个位需要I V X。所以我们在统计的时候可以按位进行,每一位上根据数字的值可以确定它使用的三种字母的数目。 代码中 num[10] ={0,1,2,3,1,0,1,2,3,1} 存储的是某一位数字0~9表示成罗马数字所需要的最小计数单位的个数(如个位来说,所需要的I的个数)。



完整代码如下:

/*
ID: gjj50201
LANG: C++
TASK: preface	
*/

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;

string roma = "IVXLCDM";
int num[10]={0,1,2,3,1,0,1,2,3,1};
int ans[7];

void solve(int n){
	int t, i = 0;
	while(n){
		t = n%10;
		n /= 10;
		ans[i] += num[t];
		if(t == 9)
			ans[i+2] ++;
		else if(t >= 4)
			ans[i+1] ++;
		i += 2;
	}
}

int main(){
	freopen("preface.in","r",stdin);
	freopen("preface.out","w",stdout);
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
		solve(i);
	for(int i=0;i<7;i++)
		if(ans[i]>0)
			cout<<roma[i]<<" "<<ans[i]<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值