ACM--猫鼠交易--贪心--HDOJ 1009--FatMouse' Trade


HDOJ题目地址:传送门

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63918    Accepted Submission(s): 21644


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500


题意:老鼠准备了M磅猫食,准备拿这些猫食跟猫交换自己喜欢的食物。有N个房间,每个房间里面都有食物。你可以得到J[i]但你需要付出F[i]的猫食。要你计算你有M磅猫食可以获得最多食物的重量。


题解:贪心算法,求最优解。将J[i]/F[i]的值从大到小排列,总是先取最大的,就能保证能够得出的最大值。

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct Node{
   double J;//每个房间有J磅豆子
   double F;//需要我付出F磅猫食
   double bi;//J和F的比值
}result[10000];
/**
  用来进行比较
*/
bool cmp(Node a,Node b){
    if(a.bi<b.bi)
        return true;
    else
        return false;
}
int main(){
   int m,n,i;
   double re;//表示有m磅猫食,n个房间
   while(scanf("%d%d",&m,&n)&&m!=-1&&n!=-1){
      re=0;
      for(i=0;i<n;i++){
         cin>>result[i].J>>result[i].F;
         //将J和F的比值录入
         result[i].bi=result[i].J/result[i].F;
      }
      sort(result,result+n,cmp);
      for(i=n-1;i>=0;i--){
          if(m>=result[i].F){
              m-=result[i].F;
              re+=result[i].J;
          }else{
              re+=m*result[i].bi;
              break;
          }
      }
      printf("%.3lf\n",re);
   }
}



  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值