ACM--过沼泽--模拟--HDOJ 5477--A Sweet Journey


HDOJ题目地址:传送门

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 759    Accepted Submission(s): 397


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:  Li,Ri , which represents the interval  [Li,Ri]  is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means  Ri<Li+1  for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
  
  
1 2 2 2 5 1 2 3 4
 

Sample Output
  
  
Case #1: 0

题意:一个人去旅行,路上有沼泽和平路,当走平路是增加a点体力,当走沼泽时消耗b点体力,求最开始最少要携带多少点体力

#include<iostream>
#include<stdio.h>
#include<memory.h>
#include<algorithm>
using namespace std;
struct Node{
   int begin;
   int end;
   int chazhi;
}zhaoze[101];
bool cmp(Node a,Node b){
   if(a.begin<b.begin)
	   return true;
   return false;
}
int main(){
  int n,m,i,a,b,l,kaishi,jieshu,result,temp,index=1;
  cin>>n;
  while(n--){
      cin>>m>>a>>b>>l;
	  for(i=0;i<m;i++){
	     cin>>zhaoze[i].begin>>zhaoze[i].end;
		 zhaoze[i].chazhi=zhaoze[i].end-zhaoze[i].begin;
	  }
	  sort(zhaoze,zhaoze+m,cmp);
	  result=0;
	  temp=0;
	  kaishi=0;
	  jieshu=0;
	  for(i=0;i<m;i++){
	     temp=temp+(zhaoze[i].begin-jieshu)*b-zhaoze[i].chazhi*a;
		 jieshu=zhaoze[i].end;
		 if(result>temp){
		   result=temp;
		 }
	  }
	  temp+=(l-jieshu)*b;
	  if(result>temp){
		   result=temp;
	  }
	  if(result<0){
	       printf("Case #%d: %d\n",index,-result);
	  }else{
	      printf("Case #%d: 0\n",index);
	  }
	  index++;
  }
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值