2499:Binary Tree

2499:Binary Tree

总时间限制: 1000ms 内存限制: 65536kB
描述
Background
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:
The root contains the pair (1, 1).
If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?
输入
The first line contains the number of scenarios.
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent
a node (i, j). You can assume that this is a valid node in the binary tree described above.
输出
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
样例输入
3
42 1
3 4
17 73
样例输出
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

分析:

以前做过,有印象,但是仍然没有思路,看了别人的代码后,理解了减法的实现,但是用除法来实现就想不通。

http://www.cnblogs.com/dongsheng/archive/2013/03/03/2942067.html

/*
题意:根(a,b),则左孩子为(a+b,b),右孩子为(a,a+b)
    给定(m,n),初试根为(1,1),从(1,1)到(m,n)需要往左子树走几次,
    往右子树走几次。
思路:逆向思维,从(m,n)到(1,1)。
    给定(m,n),求其父亲,如果m>n,则他父亲是(m-n,n),
    否则(m,n-m)。
代码一:  ----TLE
#include <iostream>

using namespace std;

int main()
{
    int T, a, b, lcnt, rcnt;
    cin >> T;
    for(int i = 1; i <= T; ++i)
    {
        cin >> a >> b;
        lcnt = rcnt = 0;
        while(a != 1 || b != 1)
        {
            if(a >= b)
            {
                ++lcnt;
                a -= b;
            }
            else
            {
                ++rcnt;
                b -= a;
            }
        }
        cout << "Scenario #" << i << ':' << endl;
        cout << lcnt << ' ' << rcnt << endl <<endl;
    }
    return 0;
}

代码二:
用除法代替减法,得到的商即为往左走的次数,最后的m=m%n。
n>m时情况类推。
需要特别注意的是:
    如果m>n,m%n == 0 怎么办?因为根(1,1)不可能有0存在,所以特殊处理一下:
次数:m/n-1m=1
*/
#include <iostream>

using namespace std;

int main()
{
    int T, a, b, lcnt, rcnt;
    cin >> T;
    for(int i = 1; i <= T; ++i)
    {
        cin >> a >> b;
        lcnt = rcnt = 0;
        while(a != 1 || b != 1)
        {
            if(a >= b)
            {
                if(a % b)
                {
                    lcnt += a/b;
                    a %= b;
                }
                else
                {
                    lcnt += a/b-1;
                    a = 1;
                }
            }
            else
            {
                if(b % a)
                {
                    rcnt += b/a;
                    b %= a;
                }
                else
                {
                    rcnt += b/a-1;
                    b = 1;
                }
            }
        }
        cout << "Scenario #" << i << ':' << endl;
        cout << lcnt << ' ' << rcnt << endl <<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值