Binary Tree---二叉树

http://poj.org/problem?id=2499

Background 
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 

  • The root contains the pair (1, 1). 
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)


Problem 
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

Input

The first line contains the number of scenarios. 
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*10 9) that represent 
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input

3
42 1
3 4
17 73

Sample Output

Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

 题意:

root为(1,1),节点(a,b)的左孩子为(a+b,b),右孩子为(a,a+b)。
求从root到给定节点(a,b)所走过的左右路径各为多少

 思路:

考虑一下(l,r)的来源,因为r!=l,若l>r,那么(l,r)来自于(l-r,r)向左;若r>l, 那么(l,r)来自于(l,r-l)向右。那么可以通过递推的不断相减得到以下的代码

#include<stdio.h>
#include<string.h>
int main()
{
    int n,flag=1;
    scanf("%d",&n);
    while(n--)
    {
        int i,j,right=0,left=0;
        scanf("%d%d",&i,&j);
        while(i!=1||j!=1)
        {
            if(i>j)
            {
                if(j==1)
                {
                    left+=i-1;
                    i=1;       ///变成1    少了这一步会出现死循环
                }
                else
                {
                    left+=i/j;   ///倍数时间优化
                    i=i%j;           ///(l,r)来自于(l-r,r)向左
                }
            }
            else if(i<j)
            {
                if(i==1)
                {
                    right+=j-1;
                    j=1;
                }
                else
                {
                    right+=j/i;   ///(l,r)来自于(l,r-l)向右
                    j=j%i;
                }
            }
        }
        printf("Scenario #%d:\n%d %d\n",flag++,left,right);
        if(n)printf("\n");
    }
    return 0;
}
/*如果a>b,我们要一次性退到b>a,可以这样:
left+=a/b; a=a-(a/b)*b;(即a=a%b);*/

不得不感慨,还得多学习啊!~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值