1020. Tree Traversals (25)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

提交代码

#include<stdio.h>

#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int n,i,j;
 struct node{
  int data;
  node*lchild;
  node*rchild;
 };
int post[50],in[50];
 node*create(int postL,int postR,int inL,int inR)
 {


     if(postL>postR)
     {
      return NULL;
}
     node*root = new node;//存放根节点的地址
root->data = post[postR];//根节点的值
//遍历找到左右子树的个数 
int k;
for(k=inL;k<=inR;k++)
{
if(in[k]==post[postR])
        break;
}
     int numberLeft = k-inL;//左子树的个数
     //赋值给左子树  
     root->lchild=create(postL,postL+numberLeft-1,inL,k-1);
     root->rchild=create(postL+numberLeft,postR-1,k+1,inR);
     return root;//返回根节点地址 
 }
 int num=0;
void BFS(node*root)
{
queue<node*>q;
    q.push(root);
    while(!q.empty())
    {
    node*now=q.front();
    q.pop();
        printf("%d",now->data);
    num++;
    if(num<n){
     printf(" ");
}
if(now->lchild!=NULL)q.push(now->lchild);
if(now->rchild!=NULL)q.push(now->rchild);
}

int main()
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&post[i]);
}
for(j=0;j<n;j++)
{
scanf("%d",&in[j]);
}
//建树
node*root = create(0,n-1,0,n-1);
//层序遍历
BFS(root); 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

测试小牛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值