Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>
 

Input
n (0 < n < 20).<br>
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>
 

Sample Input
  
  
6<br>8<br>
 

Sample Output
  
  
Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>

 

题目给一个n 输出一个圈这个圈相邻两个数 的和是素数;

思想:一开始感觉好像贪心能做 ,可是后来发现答案不一定有一种,所以还是用的dfs 条件后一个数加上前一个数是素数最后一个数加一是素数;

代码:

#include<iostream>
#include<cstring>
using namespace std;
int n, cnt = 1;
int v[21], a[21];
int P[38] = { 0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1 };
 void dfs(int cur)
 {
     if (cur == n && P[a[0] + a[n - 1]])
     {
         cout << a[0];
         for (int i = 1; i < n; ++i)
             cout << " " << a[i];
         cout << endl;
     }
     else
     {
         for (int i = 2; i <= n; ++i)
             if (!v[i] && P[i + a[cur - 1]])
            {
                 a[cur] = i;
                v[i] = 1;
                 dfs(cur + 1);
                 v[i] = 0;
             }
     }
 }
 int main()
 {
     a[0] = 1;
     while (cin >> n)
     {     memset(v, 0, sizeof(v));
         cout << "Case " << cnt++ << ":\n";
         dfs(1);
         cout << endl;
     }
     return 0;
 }








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值