Line belt

Total Submission(s) : 59   Accepted Submission(s) : 18
Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.<br>How long must he take to travel from A to D?
 

Input
The first line is the case number T.<br>For each case, there are three lines.<br>The first line, four integers, the coordinates of A and B: Ax Ay Bx By.<br>The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.<br>The third line, three integers, P Q R.<br>0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000<br>1<=P,Q,R<=10
 

Output
The minimum time to travel from A to D, round to two decimals.
 

Sample Input
  
  
1<br>0 0 0 100<br>100 0 100 100<br>2 2 1
 

Sample Output
  
  
136.60
 

Author
lxhgww&&momodi
 

Source
HDOJ Monthly Contest – 2010.05.01

 


说真的一开始没看懂这个题原因在于第一组数据太特殊了~唉还是英语水平白瞎

题意多看了几遍加上各种翻译懂了一开始一直感觉奇葩最短肯定是直线垂直。。。

后来想了懂了以后题目只要a到d并没有要求a到b到c到d。。这样就有很大问题了因为速度不一样

所以这需要有一个判定能不能走然后还要知道在那走

这样就要有两个求解的过程需要用二分或者三分

做完了一直是超时...后来没办法了把输入输出改成c的结果过了

代码:

#include<iostream>
 #include<stdio.h>
 #include<cmath>
 #include<string.h>
 using namespace std;
 struct point
 {
     double x,y;
 };
 double dis(point a,point b)
 {
     return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
 }


 double p,q,r;


 double find2(point a,point c,point d)
 {
     point left,right;
     point mid,midmid;
     double t1,t2;
     left=c;right=d;
     do
     {
         mid.x=(left.x+right.x)/2;
         mid.y=(left.y+right.y)/2;
         midmid.x=(mid.x+right.x)/2;
         midmid.y=(mid.y+right.y)/2;
         t1=dis(a,mid)/r+dis(mid,d)/q;
         t2=dis(a,midmid)/r+dis(midmid,d)/q;
         if(t1>t2)left=mid;
         else right=midmid;
     }
     while(dis(left,right)>=1e-5);
     return t1;
 }
 double find(point a,point b,point c,point d)
 {
     point left,right;
     point mid,midmid;
     double t1,t2;
     left=a;
     right=b;
     do
     {
         mid.x=(left.x+right.x)/2;
         mid.y=(left.y+right.y)/2;
         midmid.x=(mid.x+right.x)/2;
         midmid.y=(mid.y+right.y)/2;
         t1=dis(a,mid)/p+find2(mid,c,d);
         t2=dis(a,midmid)/p+find2(midmid,c,d);
         if(t1>t2)left=mid;
         else right=midmid;
     }while(dis(right,left)>=1e-5);
     return t1;
 }
 int main()
 {


     int t;
     point a,b,c,d;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%lf%lf%lf%lf%lf%lf%lf%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y,&c.x,&c.y,&d.x,&d.y,&p,&q,&r);
         printf("%.2lf\n",find(a,b,c,d));
     }
     return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值