A

Total Submission(s) : 210   Accepted Submission(s) : 40
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

 

题目大意:求个子数列让这个数列的和最大;

这个数列是连续的,并且要把子列的位置记录下来;

思路:

因为他要有起始位置和结束位置所以我就从这里入手定义了一个二维数组来存起始位置和和

最后比较去最大的和输出和其实位置和结束位置

代码:

#include<iostream>
#include<string.h>
using namespace std;
int iarr[100001];
int  dp[100001][2];
int n;
int ans = -100000000,i,p;
void dps()
{




ans = -100000000;
 dp[0][0] = iarr[0];
 dp[0][1] = 0;
 for (i = 1; i < n; i++)
 {
  if (dp[i - 1][0] +  iarr[i] >=  iarr[i])
  {
   dp[i][0] = dp[i - 1][0] +  iarr[i];
   dp[i][1] = dp[i - 1][1];
  }
  else
  {
   dp[i][0] =  iarr[i];
   dp[i][1] = i;
  }}


 for (i = 0; i < n; i++)
  if (dp[i][0] > ans)
  {
   ans = dp[i][0];
   p = i;
  }


}
int main()
{
    int t;
    cin>>t;
    for(int s=1;s<=t;s++)
    {
        memset(iarr,0,sizeof(iarr));
        memset(dp,0,sizeof(dp));
        cin>>n;
    for(int j=0;j<n;j++)
        cin>>iarr[j];
        dps();
         cout << "Case " <<s<< ":" <<endl;
        if (s != t)
            cout << ans << " " << (dp[p][1] + 1) << " " << (p + 1) << endl <<endl;
        else
            cout << ans << " " << (dp[p][1] + 1) << " " << (p + 1) << endl;
    }


return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值