B

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 题目大意:算一下两个字符串中最大相同顺序的元素个数例如测试数据一的为abfb2为on三没有
想法:一开始想的是算算每个以一个字符串每个字符结尾的子串个数用个一维数组存,真的想多了,
因为比较关系问题两个子串之间是有联系的。。。一维数组很难表示。。后来想了想用二维的存
行表示第一个列表示第二个字符串所以长度如果相等dp[i][j] = dp[i-1][j-1] + 1本状态应该是上个想同的+1,如果不相同
则是上一个行不一样的和上个列不一样的中大的那个;
代码:
#include<iostream>
#include<string.h>
using namespace std;
 int dp[1000][1000];
int main()
{
    string s1,s2;
    char t;
    while(cin>>s1>>s2){
            memset(dp,0,sizeof(dp));
            for(int i = 1 ; i <=s1.length();i++){
            for(int j = 1;j <= s2.length(); j++){
                if(s1[i-1] == s2[j-1]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
            }
          }
          cout<<dp[s1.length()][s2.length()]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值