pat甲1020. Tree Traversals(已知后序和中序求层次遍历)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
 
 
tips:递归建树,广搜输出层次遍历
#include<iostream>
#include<queue>

using namespace std;

int rt,n;
int t[320][2];//模拟建树
int post[320];//后序
int in[302];//中序
int flag;
queue<int>q;
void build(int &x,int l,int r,int ll,int rr){
	if(l>r)return;
	x=post[r];
	
	int index;
	for(int i=ll;i<=rr;i++){
		if(in[i]==x){
			index=i;break;
		}
	}
	build(t[x][0],l,l+index-1-ll,ll,index-1);
	build(t[x][1],l+index-ll,r-1,index+1,rr);
	
}
void level_traversal(int x){
	q.push(x);
	while(!q.empty()){
		int tt=q.front();q.pop();
		printf("%s%d",flag==0?"":" ",tt);flag=1;
		
		if(t[tt][0])q.push(t[tt][0]);
		if(t[tt][1])q.push(t[tt][1]);
	}
}
int main(){
	cin>>n;
	for(int i=1;i<=n;i++)cin>>post[i];
	for(int i=1;i<=n;i++)cin>>in[i];
	
	build(rt,1,n,1,n);
	
	//cout<<rt<<endl;
	level_traversal(rt);
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值