poj 2334 Simple prefix compression(胡搞)

Simple prefix compression
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1861 Accepted: 813

Description

Many databases store the data in the character fields (and especially indices) using prefix compression. This technique compresses a sequence of strings A1, ..., A N by the following method: if there are strings Ai = a i,1a i,2...a i,p and A i + 1 = a i+1,1a i+1,2...a i+1,q 
such that for some j ≤ min(p, q) a i,1 = a i+1,1, a i,2 = a i+1,2, ... a i,j = a i+1,j, then the second string is stored as [j]a i+1,j+1a i+1,j+2... a i+1,q, where [j] is a single character with code j. 

If j = 0, that is, strings do not have any common prefix, then the second string is prefixed with zero byte, and so the total length actually increases. 


Constraints 
1 ≤ N ≤ 10000, 1 ≤ length(Ai) ≤ 255.

Input

First line of input contains integer number N, with following N lines containing strings A1 ... A N

Output

Output must contain a single integer -- minimal total length of compressed strings.

Sample Input

3
abc
atest
atext

Sample Output

11
 
tips:马德,至今未看懂题意;看着别人的题解慢慢的胡搞;
具体来说每一次都统计与前面一个字符串的前缀数量;然后将长度-前缀数量的长度累加起来;然后胡搞没看懂题
#include<iostream>
#include<cstring>
#include<string>


using namespace std;

int n;
string last,now; 
int main()
{
	cin>>n;int ans=0;
	while(n--)
	{
		last=now;
		cin>>now;
		
		int sz=0;
		for(int i=0;i<last.size()&&i<now.size();i++)
		{
			if(now[i]!=last[i])break;
			sz++;//统计前缀长度 
		}
		ans+=(now.size()-sz+1);//非前缀长度; 
		
	}
	cout<<ans-1<<endl; 
	return 0;
 } 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值