hdu 1394 Minimum Inversion Number(线段树求逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19626    Accepted Submission(s): 11791


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
tips;
    
    
tips:连续区间求逆序数。
1. xi.....xj ---> xi+1.... xj xi 设前者逆序数为sum,后者为sum- xi + n-xi-1
#include<iostream>
#include<cstring>

using namespace std;
const int maxn=101000;
int sum[maxn<<2];
int n,ans;
int x[maxn];
void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int rt,int l,int r)
{
	sum[rt]=0;
	if(l==r)return;
	int m=(l+r)>>1;
	build(rt<<1,l,m);
	build(rt<<1|1,m+1,r);
}
int query(int a,int b,int rt,int l,int r)
{
	if(a<=l&&b>=r)return sum[rt];
	int ret=0;
	int m=(l+r)>>1;
	if(a<=m)ret+=query(a,b,rt<<1,l,m);
	if(b>m)ret+=query(a,b,rt<<1|1,m+1,r);
	return ret;
}
void update(int a,int rt,int l,int r)
{
	if(l==r){
		sum[rt]++;return;
	}
	int m=(l+r)>>1;
	if(a<=m)update(a,rt<<1,l,m);
	else update(a,rt<<1|1,m+1,r);
	pushup(rt);
}
int main()
{
	
	while(cin>>n)
	{
		ans=0; 
		build(1,0,n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",x+i);
			ans+=query(x[i],n-1,1,0,n-1);//查询前面的数有多少大于当前数的 
			update(x[i],1,0,n); //当前值+1,并且更新相关父结点的值 
		}

		int tmp=ans;
		for(int i=0;i<=n-2;i++)
		{
			tmp=tmp+n-x[i]-1 -x[i];
			ans=min(ans,tmp);
		}
		 cout<<ans<<endl;
	}
	
	return 0;
 } 



  
  
tips:连续区间求逆序数。两点:
1. xi.....xj ---> xi+1.... xj xi 设前者逆序数为sum,后者为sum- xi + n-xi-1
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值