poj 3061 Subsequence(二分,尺取法)

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14339 Accepted: 6020

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
tips:1.二分序列长度,O(N)枚举起点验证 时间复杂度O(NLOGN)
2.如果找到某一区间符合,将左端点右移一个,然后继续寻找符合条件的区间O(N)
#include<iostream>
#include<cstring>

using namespace std;
int ans,sum,n;
int a[110000];
int s,e,cnt;
int main()
{
	int k;cin>>k;
	while(k--)
	{
		cin>>n>>sum;
		for(int i=1;i<=n;i++)cin>>a[i];
		ans=n+1;
		s=e=1;cnt=0;
		while(1)
		{
			while(cnt<sum&&e<=n)
			{
				cnt+=a[e++];
			}
			if(cnt<sum)break;
			ans=min(ans,e-1-s+1);
			cnt-=a[s++];
		}
		if(ans>n)cout<<0<<endl;else cout<<ans<<endl;
	}
	return 0;
 } 

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

int n,cnt,S,k;
int a[110000];
int sum[110000];
bool ok(int x)//x代表连续序列的长度 
{
	for(int s=1;s<=n-x+1;s++)//枚举起点 
	{
		if(sum[s+x-1]-sum[s-1]>=S)return true;
	}
	return false;
 } 
int main()
{
	cin>>k;
	while(k--)
	{
		cin>>n>>S;
		for(int i=1;i<=n;i++)cin>>a[i],sum[i]=sum[i-1]+a[i];
		if(sum[n]<S){cout<<0<<endl;continue;}
		//二分序列长度 
		int l=0;int r=n;
		while(r-l>1)
		{
			int m=(l+r)>>1;
			if(ok(m))r=m;
			else l=m;
		}
		cout<<r<<endl;
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值