POJ 2376 Cleaning Shifts(贪心)

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20842 Accepted: 5257

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.


tips:一道贪心的题目,写了挺长时间。

首先我们要根据开始时间将结构体进行排序。

贪心选择性质:

每次选择一个能覆盖begin起点的一个区间,然后从里面选择一个右端点最大 的区间。

下一次的begin起点是选择的区间右端点+1;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio> 

using namespace std;

int n,t,ans;//牛的数量,时间数,输出的结果

struct Node{
	int s,e;
	friend bool operator <(Node n1,Node n2){
		return n1.s<n2.s;
	}
}node[26000];

int main()
{
	cin>>n>>t;
	for(int i=1;i<=n;i++)
	{
		scanf("%d %d",&node[i].s,&node[i].e);
	 } 
	sort(node+1,node+1+n);
	int end=0;int index=1;
	while(end<t)
	{
		int begin=end+1;//下一个区间需要至少覆盖到begin 
		int i;
		for(i=index;i<=n;i++)
		{
			if(node[i].s<=begin){
				end=max(end,node[i].e);//选择一个可以拓展的最远的 
			}
			else break;
		}
		if(begin>end)//说明找不到一个区间覆盖begin点 
		{
			cout<<-1<<endl;return 0;
		}
		else{
			ans++;
			index=i;
		}
	}
	cout<<ans<<endl;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值