poj 3259 Wormholes(spfa)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 50350 Accepted: 18590

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


tips:spfa判是否含有负环,没优化,时间复杂度O(MN)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>

using namespace std;

int dis[555];
struct edge{
	int u,v,w;
};
vector<edge>edges;
vector<int>g[555];
int n,m,w,book[555],cnt[555];
void insert(int x,int y,int z)
{
	edges.push_back(edge{x,y,z});
	g[x].push_back(edges.size()-1);
}
int spfa()
{
	memset(dis,0x3f,sizeof(dis));
	memset(book,0,sizeof(dis));
	memset(cnt,0,sizeof(cnt));
	queue<int>q;q.push(1);book[1]=1;dis[1]=0;
	while(!q.empty())
	{
		int x=q.front();q.pop();
		book[x]=0;
		for(int i=0;i<g[x].size();i++)
		{
			edge e=edges[g[x][i]];
			if(dis[e.v]>dis[x]+e.w)
			{
				dis[e.v]=dis[x]+e.w;
				if(!book[e.v])
				{
					book[e.v]=1;
					q.push(e.v);
					if(++cnt[e.v]>n)return 1;
				}
			}
		}
	}
	return 0;
}
int main()
{
	int t;cin>>t;
	while(t--)
	{
		cin>>n>>m>>w;
		edges.clear();
		for(int i=0;i<=n;i++)g[i].clear();
		for(int i=1;i<=m;i++)
		{
			int x,y,z;cin>>x>>y>>z;
			insert(x,y,z);
			insert(y,x,z);
		}
		for(int i=1;i<=w;i++)
		{
			int x,y,z;cin>>x>>y>>z;
			insert(x,y,-z);
		}
		if(spfa())cout<<"YES"<<endl;
		else cout<<"NO"<<endl; 
	}
	
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值