HDOJ 2117 Just a Numble

Just a Numble
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4330 Accepted Submission(s): 2189

Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input
Each line of input will contain a pair of integers for n and m(1<=n<=107,1<=m<=105)

Output
For each line of input, your program should print a numble on a line,according to the above rules

Sample Input
4 2
5 7
123 123

Sample Output
5
0
8

简单的介绍一下这道题:
其实就是取某个数倒数的小数点后面的第几位小数的数值,其实题目不难,主要是让大家回顾一下除法的小数运算,具体见如下代码:

#include<stdio.h>
int main()
{
int n,m;
int result;
int num;
int s;
while(scanf("%d %d",&n,&m)!=EOF)
{
if(n==1)
{
printf(“0\n”);
continue;
}
num=10;
s=0;
while(m>s)
{
result=num/n;
num=num%n;
num=num*10;
s=s+1;
}
printf("%d\n",result);
}
return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值