C - !সহজ ~কঠিন -- (二分求幂)

C - !সহজ ~কঠিন
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description


For given integers m and n, compute mn (mod 1,000,000,007). Here, A (mod M) is the remainder when A is divided by M.

Input

mn

Two integers m and n are given in a line.

Output

Print mn (mod 1,000,000,007) in a line.

Constraints

  • 1 ≤ m ≤ 100
  • 1 ≤ n ≤ 109

Sample Input 1

2 3

Sample Output 1

8

Sample Input 2

5 8

Sample Output 2

390625
//方法有点像二分
#include <stdio.h>
#include <math.h>
#define mod 1000000007
typedef long long ll;
ll pow_mod(int a,int n){
	if(n==0) return 1;
	int x = pow_mod(a,n/2);
	ll ans = (ll)x*x%mod;
	if(n%2==1) ans =ans*a%mod;
	return ans;
}
int main(){
	int m,n,i;
	long long sum;
	scanf("%d %d",&m,&n);
	sum = pow_mod(m,n);
	printf("%lld\n",sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值