Linux下rpm包方式离线安装mysql

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_28082757/article/details/71192061

第一步
下载rpm包:https://dev.mysql.com/downloads/mysql/
这里写图片描述

下载这两个rpm包;

第二步
检查是否安装了mysql组件:
rpm -qa | grep -i mysql

第三步
删除组件
rpm -ev 组件名

第四步
进入到rpm包的文件夹下面,分别执行以下两条命令(需要root权限):
rpm -ivh mysql-community-server-5.7.18-1.el6.x86_64.rpm
rpm -ivh mysql-community-client-5.7.18-1.el6.x86_64.rpm

如果显示进度条并且是100%,则是安装成功

第五步
登陆mysql
mysql -u -p

这里不需要输入用户名和密码 因为最开始初始化时没有用户名和密码的。

安装rpm包时遇到error:Failed dependencies解法方法:
如果在安装过程中出现错误提示说需要依赖包的情况,那么在安装过程中可以加上一个或者两个参数;
rpm -ivh mysql-community-server-5.7.18-1.el6.x86_64.rpm - -nodeps
rpm -ivh mysql-community-client-5.7.18-1.el6.x86_64.rpm - -nodeps
或者
rpm -ivh mysql-community-server-5.7.18-1.el6.x86_64.rpm - -nodeps - -force
rpm -ivh mysql-community-client-5.7.18-1.el6.x86_64.rpm - -nodeps - -force

注意:”- -“ 是英文状态下的两横杠,由于显示问题,这里打的是中文的横杠,不要复制!!!

加上那两个参数的意义就在于,
安装时不再分析包之间的依赖关系而直接安装,
也就不会再提示error: Failed dependencies:这样的错误了

一般情况加一个参数就可以了。

踏实一些,不要着急,你想要的,岁月都会给你。

展开阅读全文

没有更多推荐了,返回首页