UVa 514 - Rails

https://uva.onlinejudge.org/external/5/514.pdf

514 Rails
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was
built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish
only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture)
and due to lack of available space it could have only one track.
A
5, 4, 3, 2, 1 1, 2, 3, 4, 5
B
Station
The local tradition is that every train arriving from the direction A continues in the direction B with
coaches reorganized in some way. Assume that the train arriving from the direction A has N 1000
coaches numbered in increasing order 1; 2; : : : ; N. The chief for train reorganizations must know whether
it is possible to marshal coaches continuing in the direction B so that their order will be a1:a2; : : : ; aN .
Help him and write a program that decides whether it is possible to get the required order of coaches.
You can assume that single coaches can be disconnected from the train before they enter the station
and that they can move themselves until they are on the track in the direction B. You can also suppose
that at any time there can be located as many coaches as necessary in the station. But once a coach has
entered the station it cannot return to the track in the direction A and also once it has left the station
in the direction B it cannot return back to the station.
Input
The input le consists of blocks of lines. Each block except the last describes one train and possibly
more requirements for its reorganization. In the rst line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of 1; 2; : : : ; N The last line of the
block contains just 0.
The last block consists of just one line containing 0.
Output
The output le contains the lines corresponding to the lines with permutations in the input le. A
line of the output le contains Yes if it is possible to marshal the coaches in the order required on the
corresponding line of the input le. Otherwise it contains No. In addition, there is one empty line after
the lines corresponding to one block of the input le. There is no line in the output le corresponding
to the last \null” block of the input le.
ACM Contest Problems Archive University of Valladolid (SPAIN)
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No

Yes

分析:

简单的把栈给模拟一下就可以了

//STL写法
#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>
#define INF 0x3f3f3f3f
#define eps 1e-6

typedef long long LL;
const double pi = acos(-1.0);
const long long mod = 1e9 + 7;
using namespace std;

int target[1005];
stack <int> a;

int main()
{
    //freopen("int.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    while(scanf("%d",&n) && n)
    {
        while(scanf("%d",&target[0]) && target[0] != 0)
        {
            for(int i = 1;i < n;i++)
                scanf("%d",&target[i]);
            int ok = 1;
            int A = 1,B = 0;
            while(B < n)
            {
                if(A == target[B])
                {
                    A++;
                    B++;
                }
                else if(!a.empty() && a.top() == target[B])
                {
                    a.pop();
                    B++;
                }
                else if(A <= n)
                    a.push(A++);
                else
                {
                    ok = 0;
                    break;
                }
            }
            if(ok)
                puts("Yes");
            else
                puts("No");
        }
        puts("");
    }
    return 0;
}
//数组写法
#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>

typedef long long LL;
const double pi = acos(-1.0);
const long long mod = 1e9 + 7;
using namespace std;

int target[1005];
int a[1005];

int main()
{
    //freopen("int.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    while(scanf("%d",&n) && n)
    {
        while(scanf("%d",&target[0]) && target[0] != 0)
        {
            for(int i = 1;i < n;i++)
                scanf("%d",&target[i]);
            int top = -1,ok = 1;
            int A = 1,B = 0;
            while(B < n)
            {
                if(A == target[B])
                {
                    A++;
                    B++;
                }
                else if(top >= 0 && a[top] == target[B])
                {
                    top--;
                    B++;
                }
                else if(A <= n)
                {
                    a[++top] = A++;
                }
                else
                {
                    ok = 0;
                    break;
                }
            }

            if(ok)
                puts("Yes");
            else
                puts("No");
        }
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值