Turing equation

问题 F: F.Turing equation

时间限制1 Sec  内存限制128 MB
提交19  解决1
[提交][状态][讨论版]

题目描述

The fight goes on,whether to store numbers starting with their most significant digit ortheir least significant digit. Sometimes this is alsocalled the "Endian War". The battleground dates farback into the early days of computer science. Joe Stoy, in his (bythe way excellent) book "Denotational Semantics", tellsfollowing story:

"Thedecision which way round the digits run is, of course, mathematicallytrivial. Indeed, one early British computer had numbers running fromright to left (because the spot on an oscilloscope tube runs fromleft to right, but in serial logic the least significant digits are dealtwith first). Turing used to mystify audiences at public lectures when, quite byaccident, he would slip into this mode even for decimal arithmetic, andwrite things like 73+42=16. The next version of the machinewas made more conventional simply by crossing the x-deflectionwires: this, however, worried the engineers, whosewaveforms were all backwards. That problem was in turn solved by providinga little window so that the engineers (who tended to be behind the computeranyway) could view the oscilloscope screen from the back.

 

You will play therole of the audience and judge on the truth value of Turing's equations.

输入

he input containsseveral test cases. Each specifies on a single line a Turing equation. A Turingequation has the form "a+b=c", where a, b, c are numbers made up ofthe digits 0,...,9. Each number will consist of at most 7 digits. This includespossible leading or trailing zeros. The equation "0+0=0" will finishthe input and has to be processed, too. The equations will not contain anyspaces.

输出

For each test casegenerate a line containing the word "TRUE" or the word"FALSE", if the equation is true or false, respectively, in Turing'sinterpretation, i.e. the numbers being read backwards.

样例输入

73+42=16

5+8=13

0001000+000200=00030

0+0=0

样例输出

TRUE

FALSE

TRUE

cpp:

#include<stdio.h>  
#include<string.h>   
int main(void)  
{  
    char str[110];  
    while(gets(str))  
    {  
        int num1=0,num2=0,num3=0;  
        int i,j,k;  
        int len1=strlen(str)-1;  
        for(i=len1;i>=0;i--)  
        {  
            if(str[i]=='=')  
                 j=i;  
            if(str[i]=='+')  
                 k=i;  
        }  
        for(i=len1;i>j;i--)  
        {  
            num3=num3*10+(str[i]-48);  
        }  
        for(i=j-1;i>k;i--)  
        {  
            num2=num2*10+(str[i]-48);  
        }  
        for(i=k-1;i>=0;i--)  
        {  
            num1=num1*10+(str[i]-48);  
        }  
        if(num1==0&&num2==0&&num3==0)  
              break;  
       else if(num1+num2==num3)  
       {  
           printf("TRUE\n");            
       }  
       else  
       {  
          printf("FALSE\n");  
       }          
    }  
    return 0;  
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

樱缘之梦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值