最长漂亮子串

有一小写英文字符构成的字符串,想得到一美丽子串,美丽子串的定义为:不能有连续有限个相同字符的的串。每个字符的个数用Ca,Cb。。。。Cz代替,字符串中。

输入:

第一行包含一个字符串s,1<=s的长度<=10^5
第二行包含26个整数表示0<=Ca,Cb...Cz<=10^9
输出:

输出最长美丽子串的长度
样例输入:
aabaacaa
10 10 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
样例输出:

5

代码如下:

import java.util.Scanner;

/**
 * 漂亮无重复子串
 */

public class subString {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
	    int[] bound = new int[26];      
		int[] cnt = new int[26];
		
		String s = sc.nextLine();
		int n = s.length();
		int max=0;
		
		for(int i=0;i<26;i++){
			bound[i]=sc.nextInt();
		}
		
		int i=0;
		int j=0;
		
		while(i<n){

			cnt[s.charAt(i) - 'a']++;

			if ((cnt[s.charAt(i) - 'a']) <= bound[s.charAt(i) - 'a'])
			{
				if (i - j + 1 >= max)
					max = i - j + 1;
				i++;
			}
			else
			{
				while ((cnt[s.charAt(i) - 'a'] )> bound[s.charAt(i) - 'a'])
				{
					cnt[s.charAt(j) - 'a']--;
					j++;
				}
				i++;
			}

		}
		System.out.println(max);
		
	}
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值