SMPL模型改用python3+numpy计算

SMPL自带的代码是用python2+chumpy,不太方便,还难理解,在github上发现了同样想改用python3+numpy计算的同道中人:

https://github.com/CalciferZh/SMPL

但要调不多不少的bug,分享给大家。

首先就是chumpy库只支持python2,从安装到运行都要改成python3的,不然就会各种报错,我就是就着报错一路改过来的:

 

1.安装时,因为pip版本是18,大于10,和chumpy库的setup不太一致,就会报错:

ImportError: No module named pip.req

就需要去pypi网站下载:

https://pypi.org/project/chumpy/#files

解压后,将里面的setup.py里的一句:

from pip.req import parse_requirements

改成:

from pip._internal.req import parse_requirements

然后直接用pip3用改好的文件夹安装:

sudo pip3 install /path/to/chumpy

 

2.chumpy库各种报错找不到各种模块:

那是因为python2和python3在自定义模块import路径写法上有区别:

假如你有一个脚本函数a.py和b.py存放在file文件夹中。当你想调用a函数时。写作:import file.a。但如果a.py需要调用b.py函数的话,在python2环境下a.py文件中直接用import b即可。但python3文件中a.py要调用b文件需要改写成import file.b。否则会出现no module named b

所以,当出现no module named ch的情况时,只需要改成

from chumpy import ch,或者import chumpy.ch as ch

 

3.python2和python3一些库的名字不同:

例如:no module named cPickle

pickle模块,在ython3中为import pickle,python2中为import cPickle as pickle

  • 4
    点赞
  • 13
    收藏
  • 打赏
    打赏
  • 23
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 23

打赏作者

兢兢业业小码农

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值