山东省第七届ACM省赛------Julyed


Julyed

Time Limit: 2000MS Memory limit: 65536K

题目描述

    Julyed is preparing for her CET-6. She has N words to remember, but there is only M days left. If she can’t remember all these words, she won’t pass CET-6. If she can’t pass CET-6, she will be unhappy. But if she remember too many words in one day, she will be unhappy, too. If she is unhappy, tomriddly will be unhappy. So she will remember as little words as she can in one day. For the happiness of both tomriddly and Julyed, how many words at most will Julyed remember in one day?

输入

 Multiple test cases. The first line is an integer T (T <= 10000), indicating the number of test cases.

Each test case is a line with two integers N, M (1 <= N, M <= 200), indicating the number of words to remember and the number of days left.

输出

 One line per case, an integer indicates the answer.

示例输入

5
6 3
2 1
1 2
5 2
4 3

示例输出

2
2
1
3
2

来源

 “浪潮杯”山东省第七届ACM大学生程序设计竞赛

题意:

N组测试数据,每一个测试数据包含两个数字,代表单词总数和每天最多记忆的单词,问他最少多少天可以记完所有的单词~
省赛中最水的一道题~o(╯□╰)o

AC代码:
#include<stdio.h>
#include<math.h>
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        int s=ceil((double)a/b);
        printf("%d\n",s);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值