Julyed
Description
Julyed is preparing for her CET-6. She has N words to remember, but there is only M days left. If she can’t remember all these words, she won’t pass CET-6. If she can’t pass CET-6, she will be unhappy. But if she remember too many words in one day, she will be unhappy, too. If she is unhappy, tomriddly will be unhappy. So she will remember as little words as she can in one day. For the happiness of both tomriddly and Julyed, how many words at most will Julyed remember in one day?
Input
Multiple test cases. The first line is an integer T (T <= 10000), indicating the number of test cases.
Each test case is a line with two integers N, M (1 <= N, M <= 200), indicating the number of words to remember and the number of days left.
Output
One line per case, an integer indicates the answer.
Sample Input
5
6 3
2 1
1 2
5 2
4 3
Sample Output
2
2
1
3
2
T组测试数据,对于每组数据,给出需要背的单词数N,和每天最多可以背的单词数,求需要几天背完
参考代码1:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
int main(void)
{
int i, j, k;
int t, a, b;
scanf("%d", &t);
while(t--){
scanf("%d%d", &a, &b);
for(i = 1; ; i++)
if(a <= b*i)
break;
printf("%d\n", i);
}
return 0;
}
或者直接使用ceil函数
参考代码2:
#include<stdio.h>
#include<math.h>
int main()
{
int N;
int a, b;
scanf("%d", &N);
while(N--)
{
scanf("%d%d", &a, &b);
printf("%d\n", (int)ceil((double)a / b));
}
}