POJ 3617:Best Cow Line

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18454 Accepted: 5136

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.


Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line


Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.


Sample Input

6
A
C
D
B
C
B


Sample Output

ABCBCD


题意:

给定一个长度为n的字符串s,要构造一个新的字符串t,刚开始t是一个空串,我们只能从s的头部或者尾部取得字符添加到t中,并且要保证t的字典序尽可能小。


就算是一道贪心问题吧!我们可以对字符串s进行操作,比较首尾两个字符的大小,优先将小的字符放入t中,如果s中首尾字符此时相同,则两个指针向中间靠拢,继续比较,如果哪边比较小,则把这边的字符放入t中,既然这样的贪心策略建立好了,实现就不麻烦啦~


AC代码:
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
void solve(char *c,int n)
{
    int left=0,right=n-1,s=0;
    while(left<=right)
    {
        bool f=false;
        for(int i=0; left+i<=right; i++)
            if(c[left+i]<c[right-i])
            {
                f=true;
                break;
            }
            else if(c[left+i]>c[right-i])
            {
                f=false;
                break;
            }
        if(f)putchar(c[left++]);
        else putchar(c[right--]);
        s++;
        if(s%80==0)cout<<endl;
    }
}

int main()
{
    int n;
    char c[10005];
    cin>>n;
    getchar();
    for(int i=0; i<n; i++)
        scanf("%c%*c",c+i);
    solve(c,n);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值